altsys

   

altsysという代替システムモジュール&ライブラリがあって、altsysをインストールした環境でうごくモジュールがたくさんあるのですが如何せん今回xoops初挑戦なのではいってないよ!っていう。

本日付けでaltsys 0.71aが最新版になっているのでそれをいれてみたら下記エラー発生。

Notice [PHP]: Use of undefined constant _LANGCODE - assumed '_LANGCODE' in file C:\xampp\htdocs\xoops\class\template.php line 84
Notice [PHP]: Use of undefined constant _CHARSET - assumed '_CHARSET' in file C:\xampp\htdocs\xoops\class\template.php line 85
Notice [PHP]: Use of undefined constant _LANGCODE - assumed '_LANGCODE' in file C:\xampp\htdocs\xoops\modules\legacyRender\kernel\Legacy_AdminRenderSystem.class.php line 122
Notice [PHP]: Use of undefined constant _CHARSET - assumed '_CHARSET' in file C:\xampp\htdocs\xoops\modules\legacyRender\kernel\Legacy_AdminRenderSystem.class.php line 123
Notice [PHP]: Use of undefined constant _CHARSET - assumed '_CHARSET' in file C:\xampp\htdocs\xoops\modules\legacyRender\kernel\Legacy_RenderTarget.class.php line 25

どうやら$xoops_langcodeと$xoops_charsetが正しい値を返さないため、ブラウザがエンコードを正しく判別できないせいということが判明。
現在altsys-0.71eパッチ版(XCL2.2,XCL2.1用) 使うといいよとここに書いてあるので
早速こちらからDLしました。現在不具合改善済。

0

 - xoops